Changeset 31104


Ignore:
Timestamp:
11/16/14 23:48:02 (8 years ago)
Author:
obi
Message:

allowed newer plugins as pluginversion

File:
1 edited

Legend:

Unmodified
Added
Removed
  • titan/titan/plugin.h

    r24035 r31104  
    144144                        {
    145145                                pluginversion = dlsym(pluginhandle, "pluginversion");
    146                                 if(pluginversion == NULL || (*pluginversion != PLUGINVERSION && *pluginversion != 999999)) //999999 for plugins without titan dependent
     146//                              if(pluginversion == NULL || (*pluginversion != PLUGINVERSION && *pluginversion != 999999)) //999999 for plugins without titan dependent
     147// allowed newer plugins as pluginversion
     148                                if(pluginversion == NULL || (*pluginversion < PLUGINVERSION && *pluginversion != 999999)) //999999 for plugins without titan dependent
    147149                                {
    148150                                        if(pluginversion == NULL)
Note: See TracChangeset for help on using the changeset viewer.